Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

  Click here to go to the first staff post in this thread.   Thread: Device incompatible

  1. #11
    Isn't the samsung galaxy tab S3 even getting android 9? Maybe the device can be updated.

    Android 4.4.4 is even 8 years old and I wonder that it is still in use. Technology changes, maybe you can install the game on a different device, I even play it on a 6.2 smartphone Android 8, but the current android version is 11.
    Or reinstall it from Google store.

  2. #12
    Forum Champion LynnK2015's Avatar
    Join Date
    Mar 2015
    Location
    Humming "The Soft Goodbye" Please see my signature.
    Posts
    5,162
    Quote Originally Posted by ClaudiaX68 View Post
    Isn't the samsung galaxy tab S3 even getting android 9? Maybe the device can be updated.

    Android 4.4.4 is even 8 years old and I wonder that it is still in use. Technology changes, maybe you can install the game on a different device, I even play it on a 6.2 smartphone Android 8, but the current android version is 11.
    Or reinstall it from Google store.
    I previously played HD on a Tab S3 which was released in 2013, the year when I received it as a Christmas gift. When it was unable to update beyond Android OS 4.4.2 and the battery was losing its charge too quickly, I knew it was time to buy a replacement tablet in 2019. And eventually, Hay Day will end support for versions older than 5. I'm surprised it hasn't happened yet because Android stopped supporting versions older than 8.1.
    Last edited by LynnK2015; 1 Week Ago at 07:54 PM.
    Dedicating "The Soft Goodbye" to the Supercell forums and the people who made it an awesome community, the brightest star in the evening sky.
    https://www.youtube.com/watch?v=nDVgb4pJMdI

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •