Page 6 of 10 FirstFirst ... 45678 ... LastLast
Results 51 to 60 of 94

  Click here to go to the first staff post in this thread.   Thread: Supercell ID Server Issues

  1. #51
    Fresh Spawn
    Join Date
    Nov 2020

    Can anyone else not use supercell ID?

    This morning I woke up and tried to switch accounts and my supercell IDs did not display. I hard reset the game and attempted to log back into my accounts but was unable to. Anyone else having this problem or know how to fix it?

  2. #52

    Switching Accounts w/ SC ID || Broken?

    Is anyone else having failure issues with switching accounts using the Supercell ID since the recent server/bug fix? I am experiencing the failure every time I attempt to switch accounts.

  3. #53
    Forum Legend Piper139's Avatar
    Join Date
    Dec 2014
    sig by dharmaraj in sig shop
    Clan: MN ICE #8UCRP8CL
    IGN: Piper139 #2PQQR9Q22

  4. #54
    Fresh Spawn
    Join Date
    Oct 2020
    Yea I am having same problem but I can't log out now at all to switch accounts. Sc you need to sort this quick all in my clan experiencing same thing and we in middle of a war.
    Quote Originally Posted by Powerpunch View Post
    Everything works fines games loads quick and normal just like before
    Only problem I'm facing is during changing account it's taking more time than a pop up show saying something went wrong pls try again later

  5. #55
    Fresh Spawn
    Join Date
    Dec 2018
    I can't either, I've contacted support through the game but not received any help as yet

  6. #56
    Senior Member
    Join Date
    Jun 2019
    Just a heads up: I'm getting this on iOS devices as well.
    Just finished CWL? Post your data here:

  7. #57
    Scid maintenance started.

  8. #58
    Yes I’ve tried on iOS and Android same issue I just hit the refresh button next to connected to come out of each account and then select the different one I wanna use but it’s a pain and I don’t need this during clan games lol

  9. #59
    Thank you, I found it in the bugs channel

  10. #60
    Crab Claw
    Join Date
    Mar 2020
    I get an error saying: ‘Oops, something went wrong. Try again later.’

    If I press okay it then let’s me chose an account and opens the game

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts