Results 1 to 5 of 5

  Click here to go to the first staff post in this thread.   Thread: Supercell ID doesnt work or something

  1. #1
    Fresh Spawn
    Join Date
    Nov 2020
    Posts
    3

    Unhappy Supercell ID doesnt work or something

    I've played about all the supercell games and i absoluteloy love them but sometimes i remove them to take a break of something and i have a supercell ID to not lose any progress cuz i aint starting all over again. So when i tried to log in it didnt work and i was really confused. my second account does work but when i fill in my main accounts gmail it wont send an email... it says it sent an email but it didnt cuz i checked all the possible inboxes and i didnt see anything... i did this multiple times, removed the cashe things or the other thing i can remove forgot the name. I also sent myself an email to the gmail account to see if it works at all and it works perfectly fine, just when i try to verify my gmail again it wont send then email with the code while the thingy says it did... i wanna get my account back pelase help

    kind reguards,
    me

  2.   This is the last staff post in this thread.   #2
    Have you checked the spam folder?

  3. #3
    Fresh Spawn
    Join Date
    Nov 2020
    Posts
    3
    Quote Originally Posted by Ajax View Post
    Have you checked the spam folder?
    yeah... i did multiple times i have nothing in my spam folders

  4. #4
    Furry Bunny wotanwaton's Avatar
    Join Date
    Nov 2017
    Location
    right behind you
    Posts
    16,048
    Make sure you used the 1000% correct writing of your email account which you have used during registration.
    Gmail is a good example. If you have used "@googlemail" during registration and now use "@gmail" during login then you will get NO email from scid because the system thinks it is a complete different email account!

  5. #5
    Fresh Spawn
    Join Date
    Nov 2020
    Posts
    3
    thanks but it doesnt work... im like 90% sure i did "@gmail", but i tried "@googlemail" as well and it didnt work...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •