Results 1 to 2 of 2

Thread: [Down?] Clanwarleagues/wars/ tag No response from Server

  1. #1

    [Down?] Clanwarleagues/wars/ tag No response from Server

    All morning my API has gotten timeouts, so I went straight to the source. Seems the entire API is fine with the exception of this endpoint.

    Here is my server response:
    <html>
    <head><title>504 Gateway Time-out</title></head>
    <body bgcolor="white">
    <center><h1>504 Gateway Time-out</h1></center>
    </body>
    </html>

    Getting an HTML response in my php is wrecking my script.
    So I checked the Developer site and guess what:
    Capture2.jpg

    Even the Developer site is down. It's been this way since this morning. Is it working for anyone else? Strange that just a single endpoint is broken....but I can't do any testing until I can get it working.

  2. #2
    Centennial Club
    Join Date
    Feb 2015
    Posts
    167
    I was having a ton of issues with this end point too. It seems good now though. I strongly recommend you cache the results when they work, and when it fails, just fall back to the cache. You'll take a big slow down constantly waiting for it to timeout though, assuming it goes bad again. Maybe we'll see next CWL.

    edit-There's still something wrong with the cwl end points. I just searched for the league group for two different clans that participated in cwl. One returned 404 not found while the other was fine. At least they didn't timeout I guess.
    Last edited by speakers; April 12th, 2019 at 08:44 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •