Page 6 of 6 FirstFirst ... 456
Results 51 to 53 of 53

  Click here to go to the first staff post in this thread.   Thread: [BUG] Please fix the UI

  1. #51
    Forum Guru wotanwaton's Avatar
    Join Date
    Nov 2017
    Location
    right behind you
    Posts
    12,684
    Quote Originally Posted by Rodbender View Post
    Yes. See how it's indent even on the side that does not have camera. Actually on the S10+, the indention on each side is even further in even when screen resolution is set to highest level and Full Screen mode is active. Actually I tried all the different settings to see if anything corrected.
    Here is screenshot with it zoomed all way out. Black box on top left is where the camera is located.
    Attachment 214214
    Yes that is the normal clash ui for devices with a notch or camera in the screen. Due to that more space is needed to fit your camera you have a bigger gap on the other side.


    I mentioned Boom Beach cause it's also a SC game and it also has UI icons on each side of the screen that adjust properly depending on the camera cutout position.
    Yes its a supercell game but still a different game. On my phone the notch slightly overlaps the buttons.

    Last edited by wotanwaton; December 4th, 2019 at 07:52 PM.

  2. #52
    Centennial Club
    Join Date
    Nov 2014
    Location
    In a Van Down by the River
    Posts
    121
    I personally would not care if the notch slightly covered a button and the UIs did not take away from the more important available game play area.

    The UI / camera notch indention needs to be dynamic. So, only the side that has the camera is effected, instead of both sides.
    Last edited by Rodbender; December 4th, 2019 at 09:28 PM.

  3. #53
    Centennial Club
    Join Date
    Nov 2014
    Location
    In a Van Down by the River
    Posts
    121
    I did some more digging and have found aw way to get the UI icons moved back to the edges. We know it's currently messed up trying to compensate for the notch out for the camera.

    I have a S10+ and I could not find the option to turn notch off in Setting > Apps > COC > App info > Notch off, as some mentioned.

    For the Samsung S10's I found the information in the link below.

    How to hide the Samsung Galaxy S10’s hole-punch camera cutout - https://bgr.com/2019/02/25/galaxy-s1...nity-o-design/

    Make sure you exit and close CoC first.

    Settings > Display > Full Screen Apps. On my S10+, I had to click on the 3 vertical dots on top right to access Advanced settings. Here you will see option to Hide front camera. When you enable this and go back to you home screen you will see a black across the top the thickness of your camera.

    When turned horizontally it looks like pic another OP posted in the thread:
    https://forum.supercell.com/attachme...8&d=1575930276

    I wish there was an option to just turn the notch off for just CoC, cause this turns it off for all apps.

    However, below is what my screen looked like with the notch on. Red box where the camera is located when Hide Front Camera set to off.

    Attachment 214246

    After I turned the notch off and then went into CoC the UI icons were still impeding on the game play area. I needed to exit and close CoC again and then go into Settings>Apps>CoC>Storage and clear the cache.

    After I did this the icons were moved back out to the edges. Red box is the black area Hide Front Camera set to on.
    Attachment 214247

    You can see the difference the biggest difference when you look at the UI icons on the right, and how they moved back to the edge.

    Again, I wish there was a way to do this for just CoC and not all Apps.

    Hope this helps.
    Last edited by Rodbender; December 10th, 2019 at 08:30 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •