Page 3 of 12 FirstFirst 12345 ... LastLast
Results 21 to 30 of 117

  Click here to go to the first staff post in this thread.   Thread: Builder/Training/Research Boosts and Existing Research

  1. #21
    Did you make sure to claim them in the Rewards section? If you're silver, you should get up to 10%, Gold unlocks 20%. I went with Gold, and it's working for me just fine.

  2. #22
    Junior Member
    Join Date
    May 2018
    Posts
    62
    I think the boosts only work on upgrades started after the boosts are redeemed and donít affect anything started before boosts are redeemed.
    Last edited by RaWF; April 2nd, 2019 at 04:30 PM.

  3. #23
    From what I can see, the boost for current buildings/research works kinda strange. I had 8 days 17 hours left on an upgrade when I earned the boost. I now have 8 days 1 hour remaining. That is appx 90% of the original time. So it looks like if you are already half way thru an upgrade you will not see any change.

  4. #24
    I am experiencing this issue. I grinded out enough season points to unlock the 10% perks for build times and research. I claimed the perks and confirmed they are active in the perks tab, none of my active in progress build or research times updated. The new build times and research times are active. I have rebooted the game and my phone multiple times as suggested in the FAQ without a successful resolution.

    I find this quite disappointing as the research and build time boosts were the most attractive perk to the gold tier for me and spent time to grind for the perk quickly. We already lost a day of the perks for bug issues so I hope this is resolved quickly or I may be requesting a refund.
    Last edited by VikingStomp; April 2nd, 2019 at 04:39 PM. Reason: Typo

  5. #25
    Senior Member durango95's Avatar
    Join Date
    May 2015
    Posts
    279
    I claimed the 10% discount and my towers are showing 10.8mm to max.
    Real chiefs learn the truffle shuffle.

  6. #26
    Junior Member
    Join Date
    Dec 2015
    Posts
    89
    My report above is specific to defensive upgrades, not research upgrades.

  7. #27
    am experiencing this issue. I grinded out enough season points to unlock the 10% perks for build times and research. I claimed the perks and confirmed they are active in the perks tab, none of my active in progress build or research times updated. The new build times and research times are active. I have rebooted the game and my phone multiple times as suggested in the FAQ without a successful resolution.

    I find this quite disappointing as the research and build time boosts were the most attractive perk to the gold tier for me and spent time to grind for the perk quickly. We already lost a day of the perks for bug issues so I hope this is resolved quickly or I may be requesting a refund.

    I have copied this reply from another thread

  8. #28
    Fresh Spawn
    Join Date
    Jul 2018
    Posts
    9
    Not seeing the reduced times here either. I have unlocked the research and builder boosts and they are reported as active. I have also logged out and restarted my devise to make sure the app was closed and restarted. No decrease in research or builder times.

  9. #29
    Fresh Spawn
    Join Date
    Jul 2018
    Posts
    9
    Not seeing the reduced times here either. I have unlocked the research and builder boosts and they are reported as active. I have also logged out and restarted my devise to make sure the app was closed and restarted. No decrease in research or builder times.

    (Copied from another thread on builder boost times)

  10. #30
    Same here. I had a wiz tower upgrading and ice golem in research and no change to either finish time or rate of time left. I did start an archer tower upgrade after claiming the 10% boost and it did reduce the total upgrade time.

    Please fix!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •